Loginpage is down
Incident Report for webCRM A/S
Resolved
The page is loading again.
Posted Jun 21, 2022 - 12:58 CEST
Investigating
Currently the login page is not loading - we are investigating the issue.
If you are already logged in, you should not be affected by the issue.
Posted Jun 21, 2022 - 12:56 CEST
This incident affected: webCRM Login.