Slower systems
Incident Report for webCRM A/S
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 13:04 CEST
Investigating
We are currently experiencing longer load times for some systems. The issue has been identified and we are working on getting up to normal speeds
Posted Apr 17, 2024 - 11:21 CEST
This incident affected: CRM system, webCRM Login, and Landing pages.